Go Back   CityProfile.com Forum - Local City and State Discussion Forums > United States City Forums > Arizona > Tucson
Click Here to Login

Reply
Old 05-22-2011, 06:04 AM  
Senior Member
 
rubicondevil07's Avatar

Tucson, AZ
Join Date: Oct 2010
Posts: 262 | Kudos: +15
Images: 1
All I hear is blah blah blah. I mean all I read. LOL

Anyways redoing my rock lights for this night run. Lets see how long these suckers last.
__________________

__________________
07 JKU Rubicon
www.tucsonoffroad.net
Reply With Quote
Old 05-28-2011, 10:25 PM  
Junior Member
 
xarmtdawg's Avatar

Tucson, AZ
Join Date: Oct 2010
Posts: 26 | Kudos: +11
I'm in, got to test out my hydro clutch conversion. Don't want another Gap episode.
__________________

Reply With Quote
Old 06-05-2011, 09:41 AM  
Senior Member

tucson, az
Join Date: Oct 2010
Posts: 341 | Kudos: +18
What everyone's tuckered out and asleep?.........great run fellas and ladies
Reply With Quote
Old 06-05-2011, 12:05 PM  
...slightly sane.
 
skivviss's Avatar

Tucson, AZ
Join Date: Nov 2010
Posts: 272 | Kudos: +16
Images: 1
i'm awake!

thanks for the funs.

everyone has a week to prep for elvis now.
__________________
build | pics | videos
Reply With Quote
Old 06-05-2011, 12:12 PM  
Senior Member

Rio Rico, AZ
Join Date: Dec 2010
Posts: 147 | Kudos: +12
Quote:
Originally Posted by catfish View Post
What everyone's tuckered out and asleep?.........great run fellas and ladies
I'm sort of awake... Is it lunch time yet?
So night time runs.. Lets see. Lots of lights don't help unless you are in front, other wise they are annoying. Big lights under body good to see what your hung up on. Mood lighting good for making out with in the dust. Anything like the movie "Lust in the Dust" hmmmm...

Oh back on topic.. Night time run. Slowley traveling in the dark with unknow monsters lurking in the bush with-in leaping distance... A different way to wheel.....
Thanks jim for putting this together...
Reply With Quote
Old 06-05-2011, 08:45 PM  
Junior Member
 
xarmtdawg's Avatar

Tucson, AZ
Join Date: Oct 2010
Posts: 26 | Kudos: +11
It was good getting out and seeing you guys again. Fun run! Thanks to all for your patience and help with my carb issue.

John
Reply With Quote
Old 06-05-2011, 09:48 PM  
Senior Member

Rio Rico, AZ
Join Date: Dec 2010
Posts: 147 | Kudos: +12
Quote:
Originally Posted by xarmtdawg View Post
It was good getting out and seeing you guys again. Fun run! Thanks to all for your patience and help with my carb issue.

John
It was nice meeting you.. BTW do yoiu think your fuel pump is putting out enough PSI? Is too much being bypassed on your filter? I did not think that your engine was hot enough for such a vapor lock.. Also to eliminate it put an electric pump back by your fuel tank.. Maybe the fuel line is also running on the same side as exhaust and the whole line is having a heat problem...

Just a few thought I had on the drive home last night...
Reply With Quote
Old 06-06-2011, 06:58 PM  
Senior Member

tucson, az
Join Date: Oct 2010
Posts: 341 | Kudos: +18
Quote:
Lots of lights don't help unless you are in front, other wise they are annoying.
They were a great help to ME, I could see the back of your rig perfectly
Reply With Quote
Old 06-06-2011, 07:16 PM  
Junior Member
 
xarmtdawg's Avatar

Tucson, AZ
Join Date: Oct 2010
Posts: 26 | Kudos: +11
Randy,

I don't think it was vapor lock, engine wasn't hot enough and it will at least start after it vapor locks. I think the needle and seat just had some crud lodged in it. I'm gonna replace both filters and do a fuel pressure test on my pump. It has sat for a few months so could of picked up something in the tank.

Thanks
John
Reply With Quote
Old 06-06-2011, 10:09 PM  
Senior Member

Rio Rico, AZ
Join Date: Dec 2010
Posts: 147 | Kudos: +12
Quote:
Originally Posted by catfish View Post
They were a great help to ME, I could see the back of your rig perfectly
Well see thats the problem. I couldn't see who was going to run over me... LOL I like the spot lights lighting up Chiminy...

Quote:
Originally Posted by xarmtdawg View Post
Randy,

I don't think it was vapor lock, engine wasn't hot enough and it will at least start after it vapor locks. I think the needle and seat just had some crud lodged in it. I'm gonna replace both filters and do a fuel pressure test on my pump. It has sat for a few months so could of picked up something in the tank.

Thanks
John
Ya I know it wasn't very hot at all.. its amazing what gets through filters. Hope thats all it was...
__________________

Reply With Quote
Reply

Go Back   CityProfile.com Forum - Local City and State Discussion Forums > United States City Forums > Arizona > Tucson
Bookmark this Page!

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Suggested Threads

Powered by vBadvanced CMPS v3.2.3

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.